Laravel

解决 Laravel 执行 npm install 出错问题

在 Laravel 中使用 npm 安装依赖包时会提示 fsevents 包安装出错,这个问题会导致之后执行 npm run dev 之类的命令打包生成前端文件会出错。 问题原因 问题是在 Laravel 的 npm 的 package.json 文件依赖中有 crossenv 包,crossenv递归依赖中含有fsevents包,而fsevents包不适用于windows。在windows下安装会出错。从而导致crossenv执行也会出错。 解决办法 npm 安装依赖时忽略... 阅读全文>>

Laravel 阅读: 71